GeoAnalytics Server Memory Leak

435
1
07-04-2021 11:42 PM
Jordan
by
New Contributor II

Afternoon all,

Just wondering if anyone else has experienced this, we have a stand-alone GeoAnalytics Server installed in both our Test and Production environments and on both of those two servers, we notice that the memory on the server slowly increases every day until eventually the server is unresponsive.

The server specs are:

- Windows Server 2019, 4 CPU, 16 GB RAM, ArcGIS 10.8.1

Our GeoAnalytics Server is not very heavily utilised at this stage, and we notice this slow memory leak even when no one is sending any tasks/requests to the server. 

In addition, we have several other ArcGIS Server sites and a GeoEvent Server, all installed onto the same server image, and we have never had any memory leaks on any of these servers.

Is there anything in particular I should look at to try and troubleshoot this?

I'm still not 100% sure it is GeoAnalytics that is the culprit, but so far there doesnt appear to be any other reason for the leak.

As a workaround, I currently have a task setup to reboot the GeoAnalytics server in the middle of the night, once per week, which resets the memory. I first noticed this at 10.7.1 and was hoping a 10.8.1 upgrade would solve it, but it doesnt appear to have.

Cheers, Jordan

1 Reply
JamesGough
Occasional Contributor

I have noticed the same thing on our GeoAnalytics machines. After a fresh start-up they will be at about 22% memory usage (out of 32 GB) but that seems to increase over time until all memory is in use and the machine becomes unresponsive. Like you, we are hardly using GeoAnalytics Server right now so these machines should be mostly idle. I have not seen this issue with any other ArcGIS Enterprise component, and GeoAnalytics is pretty much the only thing installed on these machines.

0 Kudos