Signing in to ArcGIS Enterprise

770
9
Jump to solution
09-18-2023 06:28 AM
GregKeith
Occasional Contributor III

Hello,

I'm trying to sign in to Power Automate in MS 365 in order to access a Survey123 form in our Enterprise organization. I can't find any option to do so. All I can do is sign in to our AGOL account.

I have a Power Automate Premium license and can access the premium ArcGIS connector. But when I click Create (step 6 in the documentation), all options, including Other Organization, limit me to AGOL and I never get the ArcGIS Enterprise info window from step 7.

How can I get this connection to work? We're currently on Enterprise 10.9 if that makes a difference. Thanks!

0 Kudos
1 Solution

Accepted Solutions
AnthonyLatini
Esri Contributor

@TL2 @GregKeith - That is correct! There are some differences between the Survey123 connector and the ArcGIS Connector. I have made a post around the latest changes in the ArcGIS Connectors for Power Automate connector. Take a look here

As a note, the ArcGIS Connector only works with ArcGIS Enterprise 11.0 and above. If you are looking to connect using the Survey123 connector directly, then I would recommend reading through this setup guide. 

How To: Create an ArcGIS Survey123 Connector for Microsoft Power Automate for Use with Arc (esri.com...

Let me know if this helps! 

View solution in original post

9 Replies
TL2
by
Occasional Contributor III

The Survey123 Enterprise Connector is different and must be set up as a custom connector.

 

How To: Create an ArcGIS Survey123 Connector for Microsoft Power Automate for Use with Arc (esri.com...

GregKeith
Occasional Contributor III

I think they just added an Enterprise connector in the last couple of weeks. It's a premium Power Automate license, but shows up when you search for 'ArcGIS' in connectors.

0 Kudos
TL2
by
Occasional Contributor III

added today.

0 Kudos
AnthonyLatini
Esri Contributor

@TL2 @GregKeith - That is correct! There are some differences between the Survey123 connector and the ArcGIS Connector. I have made a post around the latest changes in the ArcGIS Connectors for Power Automate connector. Take a look here

As a note, the ArcGIS Connector only works with ArcGIS Enterprise 11.0 and above. If you are looking to connect using the Survey123 connector directly, then I would recommend reading through this setup guide. 

How To: Create an ArcGIS Survey123 Connector for Microsoft Power Automate for Use with Arc (esri.com...

Let me know if this helps! 

TL2
by
Occasional Contributor III

I am running ArcGIS Enterprise 10.9.1 and it seems to be working.  What issues will I run into?

0 Kudos
AnthonyLatini
Esri Contributor

@TL2 - From my testing, I am not entirely sure what issues you might have with 10.9.1. I think under the hood, a great deal of the features and processes should be the same. Meaning, if you are only using CRUD-based operations such as creating, deleting records, etc., then it may work just as well against 11.0 and above. 

Let me know if you see anything crazy! 

0 Kudos
TL2
by
Occasional Contributor III

Thanks, I will just be reading FS to send alerts.  We are going straight from 10.9.1 to AGO so should be good to go.

 

Thanks!

0 Kudos
GregKeith
Occasional Contributor III

Thanks @AnthonyLatini, I'll look at those links. We're on Enterprise 10.9 for the next few months, at least. I don't see the new connector in my 365 Power Automate app though, but maybe info is in your links.

Edit: I see from your post that government rollout may take two weeks. Thanks for the info!

AnthonyLatini
Esri Contributor

Ah perfect! That was going to be my first question to you (are you in the government space), but I see that you edited it in. 😀

0 Kudos