Migrating Experience Builder Developer Edition Site to point to new data sources

255
1
Jump to solution
10-12-2021 08:47 AM
Sam_Berg
New Contributor III

Hello,

We are developing a few sites using the developer edition of the experience builder and need to create a copy of the site to point to new datasources to support a dev/test and production site pointing to different data.

I was hoping someone from the development team or the wider community could share any approaches that may work for this workflow.

I have gone through the json configuration files with a text editor and replaced portalurls, clientids, itemids, and urls.  The builder does load up the new main map but all the widgets' datasources are broken and the console reports many "data sources not found".  Stepping through the dev tools does show that the datasources being referenced do not exist in the state manager's view of the application.  I have not found any other value in the configuration which should be updated.

Any feedback and advice on updating datasources without the need to completely recreate a new site configuration would be appreciated.  Thank you!

Sam

 

1 Solution

Accepted Solutions
Sam_Berg
New Contributor III

Hello I found some success with this by going through the config files with the following approach.  I believe it may be necessary to make sure the datasourceid for child datasources matches the ID of the layer in the webmap json if that it how it is referenced. 

 

Make new copy of app folder

In \info.json update

Id

Owner

Portalurl

Username

In \config.json and \resources\config.json

Update portalurl

Update itemid of any map datasource

Update itemid, url, and datasetid of any child datasource to match the format including the datasource ID of the layer in the webmap json

View solution in original post

0 Kudos
1 Reply
Sam_Berg
New Contributor III

Hello I found some success with this by going through the config files with the following approach.  I believe it may be necessary to make sure the datasourceid for child datasources matches the ID of the layer in the webmap json if that it how it is referenced. 

 

Make new copy of app folder

In \info.json update

Id

Owner

Portalurl

Username

In \config.json and \resources\config.json

Update portalurl

Update itemid of any map datasource

Update itemid, url, and datasetid of any child datasource to match the format including the datasource ID of the layer in the webmap json

View solution in original post

0 Kudos