Failed to load map

84
1
Jump to solution
08-12-2022 08:59 AM
BrettLawson1
New Contributor

Viewing a Experience Builder Developer Edition with a custom widget in local development environment every thing work correctly.  When it is deployed to an IIS website a "Failed to create map" text failed and there are several errors in the console.  The portal info is configure correctly in the config file.  Could it be something to do with authentication or something else?  The Web map is shared as public.

index.js:2 No portal info.(anonymous) @ index.js:2


index.js:2 Load module error. TypeError: window.require is not a function
at (index):296:12
at new Promise (<anonymous>)
at SystemJS.constructor.instantiate ((index):295:11)
at init.js:1:27896
(anonymous) @ index.js:2


22(index):296 Uncaught (in promise) TypeError: window.require is not a function
at (index):296:12
at new Promise (<anonymous>)
at SystemJS.constructor.instantiate ((index):295:11)
at init.js:1:27896
2index.js:2 Load module error. TypeError: window.require is not a function
at (index):296:12
at new Promise (<anonymous>)
at SystemJS.constructor.instantiate ((index):295:11)
at init.js:1:27896

See attachment.

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
Grant-S-Carroll
Esri Contributor

I have experienced something similar, it was solved by ensuring that the dependancy section of the manifest for the custom widget was filled out. 

GrantSCarroll_0-1660339541164.png

 

View solution in original post

0 Kudos
1 Reply
Grant-S-Carroll
Esri Contributor

I have experienced something similar, it was solved by ensuring that the dependancy section of the manifest for the custom widget was filled out. 

GrantSCarroll_0-1660339541164.png

 

0 Kudos