Experience Builder - Table Widget not changing sort order

217
4
09-16-2021 12:22 PM
Labels (1)
TaraHaynes
New Contributor III

(Note: this is not fixed as of the September 2021 EB update)

The 'sorting' setting does not seem to apply properly to the table in the widget.

Steps to produce:

1. Add Table widget > New Sheet > add desired sheet

2. In drop-down, go to settings for the chosen View (I tried both the Default view and creating a new view)

3. In 'Sort', identify sort fields. Check preview to confirm desired effect, and all is well:

EBTable1.PNG

4. 'Apply Changes'

5. Changes do not appear in table within the widget:

EBTable2.PNG

I have also tried this only sorting on one field (BEC_Subzone), but with the same result. Not sure if I'm missing a step, or if this is simply a bug - any help would be appreciated!

4 Replies
BrittanyBurson
Occasional Contributor III
TaraHaynes
New Contributor III

Thank you! And thanks for the links - I tried to hunt similar topics down, but apparently I was using the wrong keywords! At least it looks like it's in the product plan... hopefully we'll see a solution soon.

Cheers!

0 Kudos
BrittanyBurson
Occasional Contributor III

I know what you mean, I find that the actual Community search rarely returns what I am looking for... I have much better luck keyword searching within Google!

The next AGO Experience Builder update is due in a few days, maybe we'll see this as part of it. It does mention some other Table enhancements.

Henry_PeleshBW
New Contributor III

Hi @TaraHaynes ,

I appreciate you bringing this issue up. We are experiencing the same issues even after the September 2021 update. Hopefully there is a fix soon.

-Henry