Experience builder printer widget - Custom template service not working

338
2
08-04-2022 01:42 AM
Labels (1)
Beany
by
New Contributor II

Hi all,

We are attempting to use the new print widget in Experience builder. When we supply the widget with the URL of the default print service from server we encounter no issues, likewise if we provide the URL of a custom service with only a couple of templates we encounter no problem.

The issue is when we provide it with a service URL for a print service that has 13 templates available within it. We are seeing timeout errors in server and browser tools, images are attached.

Can anyone confirm if there is a limit or cap as to how many templates a service can have when being accessed by the experience builder print widget? The service with 13 templates works with zero errors when utitlised as the service for web map or web applications.

Thanks!

Beany 

0 Kudos
2 Replies
ShengdiZhang
Esri Contributor

Hi @Beany ,

There is no limit to the number of templates a service can have. I have tried a service with 11 templates and it looks good.

Can you help to check if this problem lies in the service itself? Open the URL in your screenshot, click on Execute Task and see if the operation can be executed without errors.

ShengdiZhang_2-1659681181612.png

ShengdiZhang_1-1659680974730.png

Regards,

Shengdi

 

 

0 Kudos
Beany
by
New Contributor II

Hi @ShengdiZhang,

Thanks for taking the time to get back to me! 

After following your advice I can see that we are in fact getting an error with the Get Template:

Beany_0-1659689701019.png

I am unsure what is causing this as the service is published from Pro in exactly the same way as our services that do function with the print widget.

Also as mentioned before that service works when used with Web App builder or when set as the default service in portal to be used by Map viewer....

Regards,

Beany