Experience Builder Dev Edition Fly Controller not production ready?

156
4
Jump to solution
10-12-2021 03:12 AM
Muhammad_AzhaziqBin_Mohd_Azlan
New Contributor II

Hi,

I've been creating digital twin solution for my client using fly controller. All seems work well in builder mode. However, when I download the app and deployed to static server the fly controller cannot load.

Muhammad_AzhaziqBin_Mohd_Azlan_0-1634033450915.png

Muhammad_AzhaziqBin_Mohd_Azlan_1-1634033480855.pngMuhammad_AzhaziqBin_Mohd_Azlan_2-1634033493263.png


Anyone face the same issue before? The scene I used to connect with the fly controller is esri campus map scene in AGOL.

0 Kudos
1 Solution

Accepted Solutions
Junshan_Liu
New Contributor III

The jimu-for-builder package is not in the download zip, please copy it from client/dist to your download app.

This bug will be fixed in the coming 1.6 release.

View solution in original post

4 Replies
TonghuiMing
Esri Contributor

@Muhammad_AzhaziqBin_Mohd_Azlan Telling from the errors, it probably has nothing to do with the Fly Controller widget but rather some other parts. Tried to reproduce but was not successful, unfortunately.

0 Kudos
Muhammad_AzhaziqBin_Mohd_Azlan
New Contributor II

The error indicate jimu ui couldn't load jimu-for-builder.  I don't have access to the raw code of the jimu stuff. Couldn't debug further.  By the way, which experience builder version you used? I still can replicate the issue I even changed to difference scene "Esri's Redlands Campus in 3D" in 1.5. 

0 Kudos
TonghuiMing
Esri Contributor

Thanks for pointing out the version. The issue can be reproduced in 1.5 indeed, while not others or the upcoming one. Will take a look at what happens here.

Junshan_Liu
New Contributor III

The jimu-for-builder package is not in the download zip, please copy it from client/dist to your download app.

This bug will be fixed in the coming 1.6 release.

View solution in original post