ArcGIS Experience Builder SDK - Connect to Enterprise Data / Client ID

336
6
11-30-2023 02:55 PM
Labels (1)
JeffFennellUSAFennell
New Contributor III

How do you get a Client ID for Enterprise to use for Experience Builder SDK?

Because when you login to developers you have to use an AGOL Organizational account. So the Client ID will be tied to that and not to our Enterprise.

exb1.JPG

0 Kudos
6 Replies
Grant-S-Carroll
Esri Contributor

There is a section in the help that shows how to create a client id for ArcGIS Enterprise.

https://developers.arcgis.com/experience-builder/guide/install-guide/#create-client-id-using-arcgis-...

 

 

0 Kudos
JeffFennellUSAFennell
New Contributor III

I saw that, but Step 6 under Create Client ID using ArcGIS Online or ArcGIS Enterprise doesn't exist from what I see. 

After I create the application in Portal, it takes me to the item page and the only options are Overview or Settings. There is no Manage.

If I go to settings, there is an button for App Registration: Registered Info. That gives me an App ID, but that doesn't work in experience builder.

0 Kudos
Grant-S-Carroll
Esri Contributor

What version of ArcGIS Enterprise are you using?  Whats the error you recieve when you try and use the App ID from the application you have created?

Its looks like the instructions have been done using AGOL. Enterprise is slightly different, eg no manage button.

0 Kudos
JeffFennellUSAFennell
New Contributor III

We are on 11.1

This is the error when I put in the App ID 

 

error.JPG

0 Kudos
JeffFennellUSAFennell
New Contributor III

I tried it again, this time it's just goes to a blank screen, no error message

0 Kudos
Grant-S-Carroll
Esri Contributor

Hmmmm, ok. 

This what I have for reference. Note: using 11.1 as well.

GrantSCarroll_0-1701395820767.png

 

And from the item setting page using the AppID

GrantSCarroll_1-1701395886970.png

It could be being caused maybe by a CORS issue, if your portal has been restricted to certain domains. You can add in domains within the security settings of portal. If you look at the developer console of your browser, are there any errors appearing when you get the blank screen?

GrantSCarroll_2-1701396034482.png

 

 

 

0 Kudos