Adding Domain to Hosted Feature Layer Breaking Editing Widget

160
3
04-19-2024 10:32 AM
Labels (1)
RobertAnderson3
MVP Regular Contributor

I added a domain to a hosted feature layer being used in a map for a couple Experience Builders.

This then broke the URL being used to display dynamic images.

I removed the list and it fixed the images, this is still a problem that this breaks this.

But the bigger problem is now I've reverted it, my Edit widget in ExB still seems to be broken and won't actually show the layer to update, no other settings have changed.

Any ideas, or is it simply a bug?

EDIT: In addtion, in this time frame the data was shared publicly, editing is not enabled but I have always been able to edit it, and "The layer owner, organization administrators, and members of shared update groups can edit a hosted feature layer or table layer’s contents even when editing is not explicitly enabled on the layer"

In the weirdest thing, if I add a random other layer to my map (I used a Survey123 layer), and it can be toggled off, and not set up with the Edit widget at all, for all intents and purposes it's not there, I can now edit the layers I need to. But if I remove that layer again, they all break again. That makes absolutely no sense to me hahaha.

3 Replies
ChristopherCounsell
MVP Regular Contributor

I don't understand how adding a domain (assume a value list) would in any way break the list/dynamic images. It's going to be very difficult to provide advice without having specific steps to walk through and reproduce. Probably something you need to send through to support but recent cases have had mixed results.

We've hit several issues with Experience builder and the edit widget. A recent one is 'Attribute only' on the edit widget itself broke end user editability... on layers with attribute-only editing.

Honestly at this stage it's difficult to recommend Experience Builder. I've been leaning towards instant apps, or barebones experiences that are easier to troubleshoot/fix. All the design UI is worthless in the face of an unreliable app. It also still doesn't have some core functionality, like the ability to edit multiple features at the same time.

RobertAnderson3
MVP Regular Contributor

Experience Builder definitely needs some more work before I'd be happy with it. This just goes on the list. A frustrating one is when a new version of the same data schema (overwritten, or a copy/view) is being used and it breaks every single reference set up in the widgets.

What seems to have been the issue is when the layer was shared publicly, it disabled editing in the editor app. I was able to get around this by creating a hosted view and adding that to the map/editor instead (probably how it should have been done in the first place, but a few pieces of this project have been odd).

With the Instant Apps, is there a good one for simple attribute editing you'd recommend? Where would you dictate which fields the user can see/edit? In the app itself or does it need to be done in the map?

0 Kudos
RobertAnderson3
MVP Regular Contributor

I'm also noticing this morning, when I edit an attribute and select "Update" the widget refreshes, and then the update I just made is not shown, it reverts to what it was before.

The data is updated though, if I click off the point, then re-select it in the widget app it shows the change.

This is on Edge and Chrome on my desktop, where as on the iPad I have, it worked as expected.

0 Kudos