Select to view content in your preferred language

WebgisDR fails on TileCache - java.io.FileNotFoundException

208
4
4 weeks ago
LorenzMeyer1
Occasional Contributor

Hi @ScottTansley 

It seems, that you're the chosen one answering questions related to the webgisDR tool. 😀 Hopefully you can, because Esri support (https://my.esri.com/#/support/cases/tech-cases?caseNumber=03461214) couldnt.

Currently we have ArcGIS Enterprise 11.1 installed on Windows Servers 2022 (de-ch). Each component (Portal, ArcGIS Server, WebAdaptor, TileCache Data Store, Relational Data Store) runs on its own VM in Azure. On the tileCache VM a network share is created for the backup. On this share a domain user has full access to this backup location and this domain user also runs all the windows services (portal, arcgis server, arcgis data stores). The tilecache backup itself runs an has no problem at all.

But running the WebgisDR tool from the portal VM, very often fails on the tileCache backup. The WebgisDR tool returns a message like this: 

"Failed to back up the TileCache ArcGIS Data Store: ", "Url: https://tdsserver:2443/arcgis.", "{\"jobId\":\"b829bfaa-1d26-4bcc-a637-615e449514d7\",\"description\":\"Create data store snapshot 20240620-071150-68-FULL to \\\\\\\\portalserver\\\\LocalPortalBackup\\\\WebGISSite1718860306163\\\\dataStore\\\\d858d8d4-ce9e-4a01-b06b-67cc849e9fc2\",\"lastModified\":\"2024-06-20 07:17\",\"status\":\"failed\"}"

If I check the logs of the tileCache server, I see an error like something here:
<Msg time="2024-06-20T07:17:20,492" type="WARNING" code="110340" source="Data Store" process="7360" thread="21" methodName="" machine="tdsserver" user="" elapsed="" requestID="">Backup on data store machine 'tdsserver' failed. \\portalserver\LocalPortalBackup\WebGISSite1718860306163\dataStore\d858d8d4-ce9e-4a01-b06b-67cc849e9fc2\20240620-071150-68-full\tileCache\dbfiles\temp_ifc_a094355b_ce23_slpk_18_a585735327fe47c59421bbf7f851f7d8\1\temp_ifc_a094355b_ce23_slpk_18_a585735327fe47c59421bbf7f851f7d8.zip (The system cannot find the path specified)</Msg>

So all what the WebgisDR tool has to do, is to copy the tileCache backup files from the tileCache server share to the portal backup share (located on the portal server). Most of the time it works, but sometimes (very often) it fails.

The message above implies that the backup failed after copying the file from TDS (TileCache Data Store) server to Portal server, because it says it cannot find the file at destination (not at the source). 

To fix this issue, we sometimes restart the TDS service or even the portal service.

It is not an access rights problem, otherwise it would never work. It seems related to a network latency or something else. 

Do you or somebody have a tip on how to make the webgisdr tool more stable for this kind of issue? I tried to have the backup of the TDS in an Azure storage account, but unfortunately I ran into this bug here https://my.esri.com/#/support/bugs/bugs?bugNumber=BUG-000166784

Thanks

4 Replies
TimoT
by
Occasional Contributor

It's very common to get file not found type errors when you hit the windows limitation in file path length. 

https://learn.microsoft.com/en-us/windows/win32/fileio/maximum-file-path-limitation?tabs=registry

The problematic file path is over 270 characters. 

Is 'temp_ifc_a094355b_ce23_slpk_18_a585735327fe47c59421bbf7f851f7d8' something that is system generated, or is it an item that you've named in your portal. You could try shortening this and/or your shared_location path in webgisdr properties file.

Timo

0 Kudos
LorenzMeyer1
Occasional Contributor

This stuff is all generated by arcgis enterprise for portal. The tileCache data store creates those long file names during the backup and the webgisdr.bat tool  just tries to copy it. 

0 Kudos
Thomas_Puthusserry
Occasional Contributor

@LorenzMeyer1 if the backup worked before with same setting, is it because of insufficient disk space  in the portal server? 

0 Kudos
LorenzMeyer1
Occasional Contributor

There is plenty of disk space availabe. This should not be the issue. 

0 Kudos