Web Adaptor (IIS) 10.9.1 - Portal displays blank page

233
8
Jump to solution
2 weeks ago
AnthonyRyanEQL
Occasional Contributor III

Hi all,

I just installed Portal for ArcGIS  10.9.1 and the IIS Web adaptor. Configuration, etc was successful.

When I go to access Portal via the webadaptor url it now displays a blank page. If I use the standard server address:7443/arcgis/home url, the portal page opens as expected.

Have seen a previous post relating to clearing cache, site data, etc. Done this with no success.

Has anybody come across this issue in 10.9.1?

Thanks

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
AnthonyRyanEQL
Occasional Contributor III

The reason for the blank screen relates to which authentication method is enabled in IIS. By default when installing a WA for Portal, only Windows Authentication is enabled and Windows & Anon Authentication is enabled from Server sites (which work).

After going into IIS and enabling Anonymous Authentication for the Portal WA's virtual app, I am able to now reach Portal via the WA url.

Thanks for helping me with different things to check

View solution in original post

8 Replies
Scott_Tansley
Occasional Contributor

In the first instance try to access the page using "In Private Mode".  No caching of anything there and a great test tool.  If you go to the machine with IIS, what happens when you type:

https://sub.domain.com/portal/webadaptor

or

https://sub.domain.com/portal/home

Then try the second from a remote machine.  The webadaptor URL is only available on the IIS machine itself.

Also ask different people to review as well.  I've completed a development upgrade and a production new build this week with no issues.

Scott Tansley
Consulting Architect (ArcGIS Enterprise)
https:///www.geoworx.co.nz/
https://www.linkedin.com/in/scotttansley/
0 Kudos
AnthonyRyanEQL
Occasional Contributor III

Scott,

Thanks for the reply.

First url on the IIS machine gives the webadaptor configure page

AnthonyRyanEQL_0-1637814623263.png

 

Second url on the IIS machine gives me blank page

 

First url on remote machine (eg. my desktop) gives me the expected error relating to be run on the local machine

AnthonyRyanEQL_1-1637814914965.png

 

Second url on remote machine (eg. my desktop) gives me blank page

0 Kudos
Scott_Tansley
Occasional Contributor
What happens if you use Developer tools. What traces and responses can you see in the Network Tab?
Scott Tansley
Consulting Architect (ArcGIS Enterprise)
https:///www.geoworx.co.nz/
https://www.linkedin.com/in/scotttansley/
0 Kudos
AnthonyRyanEQL
Occasional Contributor III

To me it looks normal - No obvious problems/errors

It has elements

AnthonyRyanEQL_0-1637816525925.png

AnthonyRyanEQL_3-1637816632694.png

 

Has Network information with all status=200

AnthonyRyanEQL_1-1637816566230.png

 

No errors

AnthonyRyanEQL_2-1637816584353.png

 

Also,

I added another webadaptor for server and all is working as expected

0 Kudos
Scott_Tansley
Occasional Contributor

Sorry to go quiet, it was a mix of time zones and project deliverables.  :(

I've completed an 10.8.1 to 10.9.1 upgrade and a new build at 10.9.1 this week.  Neither had blank screens, except when I had installed the portal (on 7443) and before I configured it.  It took a while to 'warm up' before I got the License screen.

I configure licenses etc via a script anyway, so once that was complete, it's worked on the 7443 address and via the Web Adaptor.

Can I recommend that you possibly reconfigure the web adaptor.  Beyond that you may need to raise an esri support ticket for your specific environment.

 

Scott Tansley
Consulting Architect (ArcGIS Enterprise)
https:///www.geoworx.co.nz/
https://www.linkedin.com/in/scotttansley/
0 Kudos
AnthonyRyanEQL
Occasional Contributor III

The reason for the blank screen relates to which authentication method is enabled in IIS. By default when installing a WA for Portal, only Windows Authentication is enabled and Windows & Anon Authentication is enabled from Server sites (which work).

After going into IIS and enabling Anonymous Authentication for the Portal WA's virtual app, I am able to now reach Portal via the WA url.

Thanks for helping me with different things to check

View solution in original post

Scott_Tansley
Occasional Contributor

I'm glad you solved it.  That's weird, I've never seen a WA default to a particular form of authentication other than authentication.  Is it a new web server?  Is it picking up on previous settings.  You can delete a WA in add/remove programs, but the web.config persists in IIS which would carry these forward.  That's the only reason I can imagine this happening.  On every new web server I've implemented on, it's just given me anonymous authentication, until I specifically turn on IWA (which I try to avoid).

Scott Tansley
Consulting Architect (ArcGIS Enterprise)
https:///www.geoworx.co.nz/
https://www.linkedin.com/in/scotttansley/
0 Kudos
AnthonyRyanEQL
Occasional Contributor III

It's a relatively new server and by default they have IWA enabled which would have been fine as we normally use IWA with AD for on-premise but this one is going to be configured with SAML to mimic the login config of another environment in AWS

0 Kudos