Tiled Image Service created using Processing Template displaying and printing Dynamically

298
0
10-28-2021 01:18 AM
DeanMoiler
New Contributor III

Hi Everyone,

I've got an issue in 10.8.1 Enterprise where an Image Service, using Cached Tiles, when added to a standard WebMap will display the service as though it were dynamic, rather than using the tile cache.

The service is generated from a mosaic dataset containing RBG images, and the Processing template is used to apply a definition query (show only a subset of images in the mosaic) and to project data to 102100 so that it can be overlaid on top of the Esri/Bing World Imagery service, showing more detailed data for certain areas.

The tiles have been generated using the same tiling schema as the Esri/Bing World Imagery service.

 

When the tiled image service is added as an item to a webmap, it requests dynamic tiles:

{https://servername/context/rest/services/serviceName}/ImageServer/exportImage?f=image&bbox={......}

 

When I add the service via URL directly, Add Data --> Add Layer From Web --> 

{https://servername/context/rest/services/serviceName}/ImageServer

Tiles are requested as tiles and correctly overlay:

{https://servername/context/rest/services/serviceName}/ImageServer/tile/{13/2878/5279}

 

This also seems to affect printing, as when the layer is printed it requests the data dynamically rather than using the tile cache.

 

Is there a flag somewhere in the Item/Service to flag the service as Tiled rather than Dynamic?

 

Note 1 : I have seen a similar post back in 2016, though seems to be specific to adding data to a basemap, whereas I'm having difficulties drawing the service correctly in a webmap and when requested via a print service. 

 

Note 2 : I have copied the image service cache, to run from a map service, and the map service using the image service cache loads correctly into a WebMap, but it then does not print (or allow tiles to be cached on demand)

 

Note 3 : I do have a workaround, which is to add the image service by URL directly to a basemap, and it displays and prints fine, but the original item is still available in the portal and will display dynamically / causes other issues relating to the processing template not being referenced correctly, so fixing the cause would be ideal!

 

0 Kudos
0 Replies