Privileges to Users

105
5
08-19-2022 04:11 AM
AlainMunyaneza1
New Contributor II

Hello, I would like to ask. I have added different users to sde database and created with one user a feature class. However, if I add another user this user see the content for the previous without already having the privilege to see it. He also has the ability to edit without privilege. Any solution or workaround to check or setting not well configured?

0 Kudos
5 Replies
George_Thompson
Esri Frequent Contributor

Sounds like the user has high-level permissions that you expected. Can you provide the following info to help with this?

What RDBMS is being used?
What is the version of the Enterprise Geodatabase?
How was the user created?
Are they in a role / group?
What the permissions for that user?

I think that is a good start.....

--- George T.
0 Kudos
AlainMunyaneza1
New Contributor II

Hello George,

The issue I have currently when I sign in with another user and create a feature class. That feature class still remains with the name of sde and I think it's the cause that the user gets all capabilities to view, edit without firstly assigning to him. How can a user appear as one who created the feature on the feature class? What can cause? Everything he/she can create, appears that sde is the one who is owner or created. View here below the picture attached.

RDBMS is Postgres, Version of sde is 10.9.1.2.9. The User was created with "Create the database user tool". I am seeing if connected as another user, that the user can create even another user. The user hasn't role by default. The other who is not owner of a feature class hasn't any permissions but by default every user created then sees all content. Every user gets after created all capabilities view/edit. 

View the picture below, all users are not the owners of feature class but see the feature class.

0 Kudos
George_Thompson
Esri Frequent Contributor

Thanks for that information.

What is the name of the user that was created with the GP tool?

Based on the screenshot, it looks like you are using the same user for the connection, is that correct?

It seems that permissions may be mixed up for the users. Can you please provide the permissions for each user?

I created a new feature class (as SDE) in my Postgres EGDB and I am not able to see it by default from another data owner. This data owner was created using the GP tool.

--- George T.
0 Kudos
AlainMunyaneza1
New Contributor II

Hello George,

All users are created with the tool. The interesting thing, that feature class appearing has been created by one user not between on the two connections appearing but all the users see all feature classes that can be created by any user. The issue is that I have not even assigned any permission. On the picture, I was showing that the feature class is appearing as it is sde who created and it is a simple user who created it. 

0 Kudos
George_Thompson
Esri Frequent Contributor

It may be best wot work with Esri technical support on this. I think that there are some specific nuances that would be hard to review / troubleshoot via this forum.

--- George T.
0 Kudos