enable sync

136
5
Jump to solution
08-10-2022 05:43 PM
forestknutsen1
MVP Regular Contributor

I want to create a web map that can be used offline in Field Maps, but I am having a hard time getting things setup.

I cannot find the enable sync option for my published feature service in server manger. 

https://enterprise.arcgis.com/en/portal/latest/use/take-maps-offline.htm#ESRI_SECTION1_C0331D55CAE14...

forestknutsen1_0-1660178505643.png

Where can I find this option?

  • ArcMap 10.6.1
  • SDE 10.6.1
  • Portal/Server 10.8.1

 

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
Scott_Tansley
Occasional Contributor III

Your screen shot shows that you have Feature Access enabled.  But on the screen the grey rectangle is over the Mapping Capability.  So the Mapping Configuration (Capabilities) are displayed.  If you click on feature access, not the tick box, but the wording, the grey bar will shift to there, and the capabilities below will update to show options similar to mine.

Scott Tansley
Consulting Architect (ArcGIS Enterprise)
https://www.linkedin.com/in/scotttansley/

View solution in original post

0 Kudos
5 Replies
Scott_Tansley
Occasional Contributor III

Is your feature service a 'traditional' feature service, or a hosted feature service.

Given the tech you've described then I'm assuming traditional.  Log in to Server Manager.  Navigate to the service (in server manager) and under the capabilities tab, you will see:

Scott_Tansley_0-1660179019574.png

You must select "the Feature Access" (not just tick it, but have that as the selected option).  The operations allowed will then show you what's possible for the Feature Access option.

 

Scott Tansley
Consulting Architect (ArcGIS Enterprise)
https://www.linkedin.com/in/scotttansley/
0 Kudos
forestknutsen1
MVP Regular Contributor

Thanks Scott,

It is normal feature servers from AGS. It is not a hosted feature layer. I have feature access turned on but I don't see the same options that you have. 

forestknutsen1_0-1660237997627.png

 

0 Kudos
Scott_Tansley
Occasional Contributor III

Your screen shot shows that you have Feature Access enabled.  But on the screen the grey rectangle is over the Mapping Capability.  So the Mapping Configuration (Capabilities) are displayed.  If you click on feature access, not the tick box, but the wording, the grey bar will shift to there, and the capabilities below will update to show options similar to mine.

Scott Tansley
Consulting Architect (ArcGIS Enterprise)
https://www.linkedin.com/in/scotttansley/
0 Kudos
forestknutsen1
MVP Regular Contributor

Got it! Thanks @Scott_Tansley 

0 Kudos
Scott_Tansley
Occasional Contributor III

My pleasure.  One other thing to consider.  When the data is in SDE (Not hosting) then there are a number of options that must be set for it to work, or you get errors in the logs saying that that dataset is not prepared.  It's all documented, but it's things like GLOBALID must be enabled and, I think, archiving.  Not something I do often, but it's all the public doco.

Glad you're sorted.  All the best,.

Scott Tansley
Consulting Architect (ArcGIS Enterprise)
https://www.linkedin.com/in/scotttansley/