ArcGIS 10.4.1 to 10.5 Upgrade Failed: REST handler inaccessible...

02-21-2017 06:58 PM
MVP Regular Contributor

This is less of a question, and more to get something surfaced for other's Google searches, if they are experiencing similar symptoms...

We recently attempted an upgrade from ArcGIS for Server 10.4.1 to ArcGIS Enterprise 10.5 on Windows. The instance also included IIS Web Adapters. The upgrade went smoothly until we reached step 6 in Upgrade ArcGIS Server, where one clicks on "Continue Server Upgrade" on the ArcGIS Server Manager webpage. After working for a bit, an error is returned:
Upgrade step 2 of 2 : Failed. REST handler inaccessible when attempting to upgrade
The ArcGIS server log also shows a bunch of "REST inaccessible" warnings. 
We tried various reboots, repairing the 10.5 installs, uninstalls/reinstalls, and kept getting stuck at this step 2 of 2. Eventually we are able to complete this step, after we shutdown the IIS service completely, and tried one more time. 
At this point it appeared that the update step completed successfully, however, we were unable to register the new 10.5 Web Adapters, and we noticed more REST inaccessible warnings in the server log, such as:
<Msg time="2017-02-15T11:57:18,957" type="WARNING" code="7712" source="Server" process="4144" thread="1" methodName="" machine="xxx" user="" elapsed="">An error was encountered while synchronizing with the config store. REST handler inaccessible when attempting to synchronize</Msg>
After further investigation with Esri's help, we determined that server was not listening on port 6443, as it should've been. It was only listening on 6080. We verified this with:
netstat -ao | findstr "LISTENING" | findstr "6080 6443"
To get the application listening again on port 6443 we had to complete the following steps:
  1. Log in to the admin page at http://localhost:6080/arcgis/admin 
  2. Navigate to security/config/update
  3. Change the Protocol drop-down to HTTP Only
  4. Click Update to commit the change
    1. The web server (service) will restart.  Wait for that to complete.
  5. Change the Protocol drop-down back to HTTP and HTTPS
  6. Click Update to commit the change
    1. The web server (service) will restart.  Wait for that to complete.
  7. Using the Services.msc, restart the arcgisserver service
  8. Re-check to see if the server is again listening on 6443 by running the net stat command above.  In our case, it was.
No idea what went wrong during the upgrade to cause this disconnect on 6443, however, we are finally out the other side and successfully running 10.5. Prior to this we had upgraded three other instances form 10.4.1 to 10.5 and encountered no issues at all. The only difference being that this last system supports many more web services (~200), so perhaps a time-out somewhere along the way, given how long it takes to start-up all those services, screwed things up?
8 Replies
Occasional Contributor

Great to see there is something on the internet that even references this issue! Unfortunately, I am attempting to do the same with 10.5.1 from 10.4.1 and there are only 2 choices to navigate to on the admin endpoint, upgrade and REST... no security option  Do you know of another way to change this setting?

UPDATE: I tried to do as your post suggested and stop IIS Service completely and run the update - same outcome. Esri upgrades somehow always seem to be a 50/50 chance of ruining your day! ha

Waiting for a response from Esri as well...


0 Kudos
MVP Regular Contributor

nrichards I don't know of another way to get to http://localhost:6080/arcgis/admin/security. Sounds like you have a different, but perhaps related, issue with your upgrade. Was Esri Support able to get you up and running?

0 Kudos
Occasional Contributor

In short - Support walked me through a full disaster recovery workflow to restore the Server installation to operation... Not ideal but it resolved the issue. Seems to be quite the critical error for a straight forward upgrade process.

0 Kudos
Occasional Contributor II

I've hit the same problem.  Did ESRI provide any docs on how to recover?  I can't even get to the admin section.  It's a federated AGS and neither the AGS admin account nor a portal account will authorize.  PIA!!

0 Kudos
MVP Regular Contributor

Esri Support did not provide any docs. They walked through the process captured in the post above.

If you are not even making it that far, then I would suggest contacting Esri Support, if you haven't already.

New Contributor III

Yesterday I had the same issue when trying to upgrade our server from arcgis server 10.4 to version 10.5.1.
The server had all the following components installed:

- Portal for ArcGIS
- ArcGIS Web Adaptor
- ArcGIS Server
- ArcGIS Data Store

I had to upgrade each component following the order described in the manual you linked above.
When reaching the same step 6 of the manual I had problem, as happened with you.
Except that in my case, the manager page didn't open automatically so that I could continue the upgrade clicking the "Continue Server Upgrade" button. I tried to open the manager page manually, but found a page with two other options "Create new Site" and "Join Existing Site". At that point, I knew something went wrong but I still don't know what.

I had noticed that port 6443 wasn't working too, because I tried to open manager using it but without success.
I looked at the admin page you've mentioned and the Protocol configuration was set to 'HTTP and HTTPS'.
What I didn't do was to change it to 'HTTP' and then change it back to 'HTTP and HTTPS'.
Fortunatly, I had a way to roll back that server to the point before the upgrade started. So I did it.
Now the components are still in version 10.4, again.

Hopefully, the information you have provided will help us upgrade it with success.

0 Kudos
New Contributor

Carlos Augusto Nantes de Castilho Rivilino

I'm having the same problem (though this issue should maybe be its own thread)

Did you come up with a solution?

0 Kudos
New Contributor III

Hi David, I 'solved' the problem.

After rolling back to arcgis server version 10.4 I uninstalled it and installed the version 10.5.1.

I had to do a lot of configuration after that, I had to republish our GPServers and Mapservers. 

I know that's not what you wanted to 'hear', sorry.

0 Kudos