Additional ArcGIS Datastore Adding as Primary?

201
4
Jump to solution
12-05-2023 09:29 AM
brettangel
Occasional Contributor II

I had an issue with a datastore, NULL validation. I removed the machine from the configuration, uninstalled, deleted datastore folders, reinstalled, added patches, and I am currently trying to configure the second DS. 

My concern is that the second DS configuration is trying to name it the PRIMARY, not STANDBY. 

Has anybody had this happen before? How did you resolve it?

We're on 10.9.1

Thanks.

0 Kudos
1 Solution

Accepted Solutions
DanielBrumm1
Occasional Contributor II

Are you seeing it called 'Primary' when you are running the Datastore Configuration utility? I get that everytime I try and add my standby back to the site. At 10.8.1 it would call it "Standby" in the configuration. Not sure why it doesnt do that anymore.  Its not a big deal. It should add it correctly once it completes. 

Daniel Brumm
GIS Nerd

View solution in original post

0 Kudos
4 Replies
DanielBrumm1
Occasional Contributor II

Are you seeing it called 'Primary' when you are running the Datastore Configuration utility? I get that everytime I try and add my standby back to the site. At 10.8.1 it would call it "Standby" in the configuration. Not sure why it doesnt do that anymore.  Its not a big deal. It should add it correctly once it completes. 

Daniel Brumm
GIS Nerd
0 Kudos
brettangel
Occasional Contributor II

Yes, it's showing PRIMARY in the config utility. I had the same experience at 10.8.1 being named STANDBY in the config, hence my apprehension. 

I have had my fair share of issues with DS so I am cautious of any changes. I put in a ticket with Esri. 

Thank you for the feedback and hoping this is the fix. I'll follow up when it's resolved.

0 Kudos
brettangel
Occasional Contributor II

You are correct! When adding the additional datastore it shows as primary even if a primary is already configured. 

Note from support:

When using the config wizard for DS it always lists them as PRIMARY, even if it’s an added DS. Is this true?----That is correct, it lists as Primary. However, to be on the safer side, we do need to check if the configuration has been changed. In most of the cases, command line utility has worked in configuration of datastore successfully.

0 Kudos
brettangel
Occasional Contributor II

After talking with support they suggested trying the configuredatastore utility. This registered the additional datastore as standby.

This does not address why the config wizard says the additional DS is primary, which is confusing, but I was able to get back to a PRIMARY & STANDBY DS.

0 Kudos