Web Adaptor Install prompting for username & password

189
3
Jump to solution
09-14-2021 09:51 AM
Labels (1)
Big-Chill
New Contributor II

Hi there,

We are experiencing a weird issue with the installation of our Portal Web Adaptor.  Our current configuration is a three tiered system with Portal, Sever, and Web Adaptor on their own virtual VM.  We started experiencing issue with our Portal Web Adaptor configuration so we decided to remove and re-install (as suggested by Esri).  During our installation/configuration of the new Portal (with the same name), we are prompted for user credentials.  We have never experienced this before and it appears to be causing an issue.

This is not our first configuration of such a system.  Actually, its our third.  We have never experienced an issue like this before.  Is there a reason why the server is requiring credentials for a new Portal Web Adaptor with the same name?

BTW, we followed Esri's documentation on the proper way to remove/uninstall the Web Adaptor.

Our environment is 10.8.1 on Windows Server.

Any help would be greatly appreciated.

Jim L.

0 Kudos
1 Solution

Accepted Solutions
Big-Chill
New Contributor II

Finally figured it out.  Under the Authentication for IIS on our Web Adaptor, we had to disable Windows Authentication and enable Anonymous access.  This allowed us to create Admin accounts prior to updating the IWA (Integrated Windows Authentication)

View solution in original post

3 Replies
ReeseFacendini
Esri Contributor

In order to link a web adaptor to ArcGIS Server or Portal, an admin username / password must be provided, regardless of the name of the web adaptor.  If you enter a Portal admin username and password, does the config work or are you seeing errors on the browser page?

0 Kudos
Big-Chill
New Contributor II

Hi Reese,

Thanks for your response.  Like I've mentioned, we have done this several times before.  This is an exact replica of an existing configuration.  I have Admin privileges on all machines.  The credentials verification screen is a Windows Security iexplore screen.  Nothing to do with PortalAdmin.

0 Kudos
Big-Chill
New Contributor II

Finally figured it out.  Under the Authentication for IIS on our Web Adaptor, we had to disable Windows Authentication and enable Anonymous access.  This allowed us to create Admin accounts prior to updating the IWA (Integrated Windows Authentication)

View solution in original post