Portal - getting "common name invalid" error on webmap

130
1
07-28-2022 09:16 PM
MichaelBell
New Contributor III

I've created an ArcGIS Enterprise install (server, portal, two webadaptors, datastore, all on the same machine) and have just tried publishing a webmap to it from ArcGIS Pro. This worked fine. However, when I come to access it, I'm getting this error:

MichaelBell_0-1659067959973.png

 

Does anyone have any idea for this one? Obviously it's pointing at certificates, and I believe they're all set up (it's pointing to my machine.domain.com as the CN - so that would be without a https:// or port).

One thing I am thinking is this could be because I've got a hyphen in the machine name (also in the domain, but looking at the GET requests the domain is being substituted for something else), and a few posts I've looked at indicate that ArcGIS Server doesn't like having numbers in the machine/domain. I wonder if it's the same for hyphens...

EDIT - incidentally, I'm just looking at my certification path and noticed that I've got two certificates above mine. Would these both need to be imported into Portal (and whatever else)? If so, where would they need to go?

MichaelBell_0-1659069074476.png

 

0 Kudos
1 Reply
ChristopherPawlyszyn
Esri Contributor

This may have to do with improper federation of the ArcGIS Server site to the Portal for ArcGIS organization, since the URL used to access the service is using a different domain (*.qx.internal.cloudapp.net) than the public Portal URL (which looks to be using a subdomain of com.au). If the web adaptors (or load balancer listener) is on the same public host, then the Services URL used for federation should use the valid HTTPS URL for the ArcGIS Server site.

 

The error you are seeing is specific to the browser instance you have open, so importing certificates on Portal wouldn't help unless you see it using the Sharing/Proxy endpoint in those failed requests (which I don't suspect to be the case).

0 Kudos