Error when adding item to My Content in Portal

3489
2
11-09-2016 12:50 PM
LukeDriskell
New Contributor

When I try to add a shapefile to Portal 10.4 using My Content > Add Item > From my computer, I get the message, "There was an error" and in the bottom of the modal I then see the text "fjsontoken" followed by a few lines of characters (see screenshot). This seems to happen regardless of file type and whether I publish as a hosted layer.

For the general Portal setup, all on Windows: Portal and its web adaptor are on one machine, ArcGIS Server and its web adaptor are on another machine, and ArcGIS Data Store is on another. The Data Store is registered with Server, and Portal has it added as a federated server and selected as the Hosting Server. I get green checkmarks for the Server and Data Store in Portal and Server Manager, respectively. 

The ArcGIS Server Site logs have some debug-level messages that might be related? Notice that one is for my local domain and another is for arcgis.com:

Token is not a valid Admin token. Trying portal token next. Token = AXttsgwC1tzuGWWINbJx-EukDYDOrqcTPgLOigmbQ7dzLzICJmuEXb7syUU_ZXX-h0DTB6HLfTfUvQf5rUHVXxkt7FcGygEJGuLAZZr2EA_mpfiFAKksM97PGKDlqFTRySztXnG_8unhAu_-a4y5pbuhaVfoAVOpaaTSfMGHzILQgNvJcdRAzSyd184Kl7ys, referrer = http://portal.domain.com/arcgis/home/content.htmlCould not decrypt token. Token may not be valid. Admin

Token is not a valid Admin token. Trying portal token next. Token = k37RBtbGVOrBZB98u-3YWHmfk0mvmjBYbWGmcsfAtX3x_6RT5fDgZwkqUixlybErzKuk2OkTag-p_P9oyEVYZJL9soE8P7_vCoMbjuHCGzDylFVhP_YtawLEqYovN7hrhozcuJky8ydfjSBCAXucJQ.., referrer = http://www.arcgis.com Could not decrypt token. Token may not be valid. Admin

Tags (1)
0 Kudos
2 Replies
RyanUthoff
Occasional Contributor III

I believe your problem is a known bug. Try using Internet Explorer and see if it works. ESRI has also released a patch for Portal as well that fixes this problem.

Bug Documentation: Announcement: Errors Encountered in ArcGIS for Server and Portal for ArcGIS Web Apps after Certain B... 

Patch: Portal for ArcGIS Home Application Upload Patch 

0 Kudos
LukeDriskell
New Contributor

Thanks a lot. That was the issue. 

0 Kudos