Legend in Graph in ArcGIS Dashboard not showing Year in consecutive order.

97
0
09-17-2021 02:32 PM
SArcher
New Contributor III

I have created a ArcGIS Dashboard with multiple Graphs. The Data is using Grouped Values from Category Field (Type-Numeric), Split by Field (Year), Statistic/Field (Type-Decimal).

The Legend in Graph (A) shows the Years in consecutive order, which is correct, using Configurations (A). 

A. Graph                                                                                                                          A. Configurations

1.PNG        2.PNG

However, I have a simular Graph (B) which uses the same Configurations (B) as A (although Category Field is different both are numeric field types), but the Legend in Graph B is NOT showing Years in consecutive order.

B. Graph                                                                                       B. Configurations

4.PNG

      3.PNG

 

 

 

 

 

 

 

 

 

Any Ideas why it's not consistent and one graph is showing correct while the other is not? Since the Year is numeric field type either way it should be going in order.

I also really would like to see the Series have a custom sorting feature rather than going by ascending/alphabetical order (or whatever order it feels like that day) especially for issues like this regardless of field type. In the long run, I have had to create numeric fields/coded values for text values just so I can have them show up in a certain order in a graph. Those extra steps don't make too much sense to me.

5.PNG

0 Kudos
0 Replies