Spatial Join Issues

1057
3
12-01-2020 12:09 AM
Bashu_Acharya
New Contributor

Hi all,

I have having some issues with Spatial join while performing a simple spatial join with my cities layers with hospital layers. 

I got different results when performing spatial join from table of content and the one done from toolbox>analysis tool>overlay>spatial join with match option set to closet for the same set of feature class. Projection is set to South Dakota Albers Equidistant Conic - is a custom projection.

Bashu_Acharya_0-1606809528647.png

Above shown is the result from toolbox

Bashu_Acharya_1-1606809584483.png

Above shown is the result from layer spatial join.

Not sure why some of the records count has different values. For instance records 2, 3, 5.

 

Bashu_Acharya_2-1606809897833.png

Bashu_Acharya_3-1606809932064.png

Circles features are associated with wrong hospital when performing closest spatial join.

Please advise on this.

0 Kudos
3 Replies
DavidPike
MVP Frequent Contributor

I t may be tripping over on your custom projection.  Have you tried closest_geodesic as an input parameter?

0 Kudos
Bashu_Acharya
New Contributor

Hi David,

Below are the parameters I used for the custom projection and yes I did try with closest_geodesic as well. Still got same result. I kind of have an idea that performing spatial join from the table of content is giving me some misleading answers and compared to one performed from toolbox with more options. I am curious about the fact that why my answers for the same task is different.  

Bashu_Acharya_0-1606839565560.png

 

0 Kudos
DavidPike
MVP Frequent Contributor

Hmmm, projection looks absolutely fine.

I've never used the table of contents spatial join before, but the available options seem suspiciously limited (as you say).

I'll make a note to avoid that particular method 🙂

 

0 Kudos