Configure Qt kits using AppStudio Advanced Configuration Tool

12-20-2016 02:58 PM
Esri Contributor
1 2 1,337

AppStudio for ArcGIS 1.3 ships with a new “Advanced Configuration Tool” that allows you to configure AppStudio components such as AppFramework, Runtime libraries, configurations for Local Make, Doc configurations with any external Qt Creator, so that you can run and debug AppStudio apps in Qt Creator.

Why do you need it?

This is a provision for developers who already have an existing licensed version of Qt, to enable them to work with AppStudio applications. However, you don’t need the Advanced Configuration to develop or build apps via cloud Make using AppStudio’s Qt Creator.

It is a highly recommended to use the Advanced Configuration if:

  1. You have an enterprise version of Qt other than the one which comes with AppStudio
  2. You want the ability to debug apps in QML Scene
  3. You want to perform local Make instead of cloud Make to generate binaries for your apps
  4. You want the complete AppFramework documentation in your Qt Creator (the Qt Creator which comes along with AppStudio is pre-configured)

Points to remember

  1. Every time you install a licensed version of Qt and reinstall AppStudio, you will want to use the Advanced Configuration Tool to configure with the Qt kits.
  2. You don’t need to use Advanced Configuration Tool if you don’t have a commercial license of Qt.
  3. If you are configuring on Windows, you want to be sure the Qt and AppStudio installer versions match (for e.g. 64-bit AppStudio with a 64-bit Qt).
  4. Qt can only be configured to produce apps for certain platforms, depending on your own operating system. iOS, for example, is not available for Windows systems. The Advanced Configuration Tool will only display platforms available for your operating system.
  5. You can always use the help icon located at the bottom left of the window to visit the web documentation page.


For more information on the advanced configuration tool, including a step-by-step guide,

see Configure with Qt kits in our documentation.

Occasional Contributor III

I have upgraded to the latest AppStudio 4 and I can get my build and run using the AppStudio Player on my phone, and creating an ARM7 build and sideloading my android.  However, when performing a local build for iOS, the app builds without errors, but when sideloading it just goes straight to a white screen.  I thought it might my app itself, but I downloaded the latest survey123 template in appstudio, did the local iOS build, side loaded the app, and it starts then goes straight to a white screen.

I have created hundreds of these builds with this code on the previous version of AppStudio.  I have QT 5.12.3 with QT IFW 3.0.6.  I do notice however that when using the Advance Configuration Editor, I select the path of my QMake and hit continue and the screen just spins. 

Has anyone else tried a local make of the Survey 123 template for IOS and sideloaded?

Am I missing some step to setting up the development/build tools for the new version?  I would expect the make process itself to fail if i had set something up incorrectly?

Please Advise

New Contributor II


I want to perform local Make instead of cloud Make to generate binaries for my apps.
So i created locally installation files for an Appstudio 4 application for Android on Windows 10 Enterprise.
For that i installed development tools locally following the official doc
ArcGIS AppStudio 4.0.93 (64-bit)
Visual Studio 2019,
Qt 5.15.2 for Windows (VS 2019) and Android (64-bit)
Android SDK Platform Tools and Android SDK

When i try to configure with qt kit for arcgis appstudio, i'm having an error saying "either the user does not have the appropriate permissions or the defined paths are not valid"



I opened AdvancedConfiguration.exe with my local admin account and redo the configuration: same error.

It is therefore not linked to the rights of the Windows account.

For info, i'm using a trial commercial licence for Qt SDK.

I don't know if you were able to set up the right environment for the local generation.
Do you have any idea how to solve this?