ArcGIS Pro: Error when sharing map

1627
3
08-19-2020 12:06 PM
Labels (1)
ErikGarcia
New Contributor

Hello,

I have always shared maps as pdf's this way, Share-> Layout and export my map into a server folder. I haven't had any issues until now, trying to export it causes this error message to appear: "Object reference not set to an instance of an object." I would appreciate any advice.

0 Kudos
3 Replies
by Anonymous User
Not applicable

Hi Erik Garcia‌,

This error occurs when a variable is empty or null. Likely something is missing when trying to save the pdf. 

I would double check the save directory, title or any other variables on the pdf export tool.

Otherwise if that does not work, best way to troubleshoot is to rule out what could be causing the errorfrom within your template. save a copy and start to remove items, try run the tool after removing each item, hopefully you will find the troublesome template item that is causing the error and can go from there.

Cheers,
Cam

ErikGarcia
New Contributor

Hello Cam,

I started deleting all the items I added yesterday because before that day it was exporting maps fine, but I still kept getting the same issue. I decided to create a new project and import my geodatabase into it. This works now, not sure what could have gone wrong. Thanks again!!!

0 Kudos
by Anonymous User
Not applicable

Hey Erik Garcia‌, 

No dramas, glad you found the issue! Looks like Pro was having trouble connecting to the geodatabase. and on export throwing the error!

Cheers,

Cam