3D Webscene symbolize by attribut including less-than (<) or grater-than (>) not working in ArcgisOnline

650
1
Jump to solution
02-03-2023 02:26 AM
DirkSilbermann
Occasional Contributor II

 

We use classified 3D-Scenelayer data to visualize for example water/floods in 3d webscenes on ArcGisOnline, e.g. here.

Doing so we classified data by text attributes and choose symbolisation for the classes in 3D-style editor, which worked fine until now (Jan2023). The text attributes are used in Legend and Popups as well.

However, now all attribute-values including less-than (<) and greater-than (>) signs are not shown correctly in webscenes anymore, and also are not recognized correctly in Webscenes 3d-style editor:

Style_Editor_Detail.jpg

If we edit the values in the style-editor again, it workes for the session, but once the webscene is saved and reloaded the problem appears again.

We are quite puzzled now about that effect, but still want to use this usefull symbols for classification and Legend/Popups.

Hopefully ESRI can fix this new bug quickly, otherwise any workarrounds would be helpfull.

0 Kudos
1 Solution

Accepted Solutions
DirkSilbermann
Occasional Contributor II

Problem has been resolved: BUG-000154645

"This issue is stemmed from sanitizing the web map JSON on save. Saved maps that show this issue have bad JSON saved. After the next Map Viewer update, regenerate the unique value style on the layer and re-save the map to see the fix."

View solution in original post

0 Kudos
1 Reply
DirkSilbermann
Occasional Contributor II

Problem has been resolved: BUG-000154645

"This issue is stemmed from sanitizing the web map JSON on save. Saved maps that show this issue have bad JSON saved. After the next Map Viewer update, regenerate the unique value style on the layer and re-save the map to see the fix."

0 Kudos