ssabatine

Snapping to a Raster with Spline with Barriers

Discussion created by ssabatine on May 18, 2012
Latest reply on May 18, 2012 by ssabatine
Hi-

I've come across what seems to be a bug in ArcMap 10. After searching for the tool "Spline with Barriers" using the search window, two paths for the tool appear: 1) Spline with Barriers (3D Analyst) and 2) Spline with Barriers (Spatial Analyst). Basically, the Spline with Barriers (3D Analyst) does not snap to another raster correctly, but the Spline with Barriers (Spatial Analyst) does. Here is exactly what I do:

Search for 'spline with barriers'.

Click Spline with Barriers (3D Analyst)
-Define Input point features
-Define Z value field
-Define Input barrier features
-Define Output cell size (same as raster I am trying to snap to)
-Define the location of the Output raster
-Smoothing Factor = 1
-Environments > Processing Extent > Snap Raster: Define raster to snap to
The resulting interpolated raster is not aligned with the raster I am snapping to.

Click Spline with Barriers (Spatial Analyst)
-Define Input point features
-Define Z value field
-Define Input barrier features
-Define Output cell size (same as raster I am trying to snap to)
-Define the location of the Output raster
-Smoothing Factor = 1
-Environments > Processing Extent > Snap Raster: Define raster to snap to
The resulting interpolated raster is aligned with the raster I am snapping to.

I also noticed that a dialog box comes up when the Spatial Analyst version is used, but not when the 3D Analyst version is used. I attached an image of what's happening. Hope this helps.

[ATTACH=CONFIG]14423[/ATTACH]

Attachments

Outcomes