d.josepha-gis4c-esridist

Need a workaround with tool.

Discussion created by d.josepha-gis4c-esridist on May 11, 2012
Latest reply on May 14, 2012 by d.josepha-gis4c-esridist
Hi there,

I've made this tool and it doesn't perform like i want to.

[ATTACH=CONFIG]14257[/ATTACH]

Explaining:

Topo: Folder containing CAD Datasets

My problem is some of the feature classes (in this example, the point feature class) in some of the CAD Datasets  doesn't contain any features.
Example:
CAD Dataset 1 has: Polyline Feature class which contains 2 features, Polygon Feature class which contains 2 features and Point Feature class which contains no features.
CAD Dataset 2 has: Polyline Feature class which contains 2 features, Polygon Feature class which contains 2 features and Point Feature class which contains 2 features.

So when my model iterates through the first cad dataset, performs the CAD to Geodatabase; It DOESN'T send a Geodatabase Point Feature class out because the CAD Point Feature class didn't had any features.
When it iterates through the second cad dataset, performs the CAD to Geodatabase; It DOES give a point feature class out but it cannot perform the "Select Data" tool because  it is "deactivated" when the model performed the first iteration.

Noticing this i've inserted a calculate value that checks that if there's any Point Feature class after the CAD to Geodatabase  tool, but it doesn't work either (doesn't perform the select data fpr the point feature class).

The script in the calculate value tool is :

FCP('%Beta%')

def FCP(Point):
  import arcpy
  arcpy.env.workspace = "C:\Users\david\Desktop\Topo\Alpha.gdb\Beta"
  if arcpy.Exists("Point"):
    return True
  else:
    return False



Can anyone help me with this, on how i might get it to work.

Thank You
David.

Attachments

Outcomes