ScottChang25

ArcGIS10:Adding model objects in ModelBuilder-Creating Feature Class. no parameters?

Discussion created by ScottChang25 on Feb 22, 2012
Hi all,

I have a book "Getting To Know ArcGIS  ModelBuilder" written by David W. Allen (published by ESRI Press, 2011).  In my ArcGIS 10 program, I have done the Exercises 1a (Examing exist models) and 1b (Creating toolboxes and models).  I am doing the Exercise 1c (Adding model objects): I did Steps 1, 2, 3 4, 5, and 6 (on Pages 17 to 21) and I found out that I did some mistakes in this Exercise 1c and the error messages were: (i) Feature Class Name: PD_1234 already exists, (ii) Create Orleander FC: This tool has no parameters, etc.  I tried to do "Create Feature Class" again for Step 4 (on Page 19) without any luck - see the attached file.  I want to re-do this "Create Feature Class"  for Step 4 (on Page 19), "Set the template feature class to Accident Schema" for Step 5 (on Page 20, and "Import and select the Accident Template feature class" for Step 6 (on Pages 20-21) to get "Create Oleander FC" with the "blue-colored" Accident Schema and Results.gdb, "yellow-colored" Create Feature Class, and "green-colored" PD_1234 shown up in the figure on Page 21.  Please kindly help and advise me how I can fix the problems and how I can get a new Create Feature Class, the Accident Schema, the Accident Template, and the "blue-colored" Results.gdb to link up with the "orange-colored" Create Feature - "green-colored" PD-1234 on the figure shown on Page 21.

Thanks,
Scott Chang

P. S.  If I clicked on the OK button of the "Create Orleander FC: This tool has no parameters" dialog box, I got Error: ERROR 000735: Feature Class location: Value is required.
                        ERROR 000735: Feature Class name: Value is required.

Outcomes