Errors importing excel file into geodatabase

Discussion created by christabelmcc on Oct 9, 2011
Latest reply on Oct 10, 2011 by christabelmcc
I am attempting to import an excel table into a geodatabase via ArcCatalogue. The table has 240 attributes (I actually want to finally have a table with around 1000 attributes but as discussed in this thread there is a limit to how many attributes can be imported at once). The attribute columns, apart from the first which an ID column, are named 1, 2, 3, 4, so on up to 240. The table itself doesn't have any geographic data in it- the ID column has a key that corresponds to records in a shapefile, so the idea is that once this table is imported I would join it to the shapefile.

When I use the 'Import to dBase' or 'Import to geodatabase' by right-clicking on the excel file, in the 'field map' field  of the Table to Table tool the the names of my attributes change from '1' to 'F1', '2' to 'F1_1', '3' to 'F1_12', '4' to F1_12_13' etc., a naming convention which would not be useful for me! This change only happens, by the way, once I nominate the output location.

If I go ahead and create the table anyway, I get a 'File does not exist or is not supported' error, even though i) I performed the operation by right-clicking on the desired file, therefore the file must be there, and ii) the help on this topic states that excel files are a valid files for this operation.

I've tried following various directions I've read about converting excel files to dbf files- I've auto-width'ed all the columns, for example, and all numbers are decimal-free none of the column widths are greater than 4 digits- yet the table to table loader still assumes all the attributes are doubles. I wonder if this is a part of my problem.

I've also tried importing the data as a .csv rather than excel, but again get a 'File does not exist or is not supported' error.

Any idea about why my import does not work? I've attached the excel file if that helps.