Network analyst v10 bug - building

Discussion created by shakesa on Aug 24, 2011
Latest reply on Aug 25, 2011 by jsandhu-esristaff
We have a road network in ArcSDE v9.3 (unable to upgrade sde yet). Using ArcGIS Desktop v10 SP2to make simple edits to the geometry & attributes of the source featureclass (eg oneway field), the 'build' function reports the network as already built. When you test the network, the changes are not realised.

Work around attempt 1
Copy the feature dataset to a v10 fGDB - similar result. This time, the build function returns the following weird error (see attachment: nwerror.jpg) Tried building within an edit session, no result.
Have to delete and re-create the nework dataset to use.

Work around attempt 2
Copy the feature dataset into development ArcSDE v9.3. Delete, recreate and build the network dataset. Tested and works. Copy to production sde, attemped to build, again same error that the dataset is already built. Wont work when tested - reports the network as needing to be built.

Work around attempt 3
Delete, re-create and build the network dataset in production ArcSDE v9.3. Works.

Haven't tested in ArcSDE v10 yet as we aren't able to upgrade yet.