lbowman

Non Versioned Editing (esriMESMNonVersioned) error in ArcMap 9.3.1

Discussion created by lbowman on Jul 28, 2011
Hello,

We have a custom ArcMap toolbar that facilitates editing our zoning map - used every 4 years. The last time used we were using ArcGIS 9.2 and the below code worked successfully. Now we are using ArcGIS 9.3.1 and I am getting an error: Exception from HRESULT:0x8004056E

I've copied the portion of the code that produced the error - the line producing the error is the StartEditing line.

I've attached an image from ArcCatalog of the feature class' properties so you can see that it is versioned with move edits to base.

Does anyone know if esriMESMNonVersioned is not working in 9.3.1 or if I need to do something differently. Again, this exact code worked in 9.2.

Any ideas would be appreciated! Otherwise, I'll just create a version for it and edit the version.

Thanks,
Laure

' Get the current Editor option to edit a non-versioned dataset
pEditProps = pEditor
pEditProps.MultiuserEditSessionMode = esriMultiuserEditSessionMode.esriMESMNonVersioned

' Start editing Worksapce
If Not pEditWorkspace Is Nothing Then

pEditor.StartEditing(pEditWorkspace) ' Line producing error

End If

Attachments

Outcomes