SRoberts

Linear referencing - measure in miles - measure rounded to nearest integer

Discussion created by SRoberts on Jul 21, 2011
Latest reply on Nov 14, 2011 by SRoberts
I have a fairly simple application where I want to create a measure system of miles for a subset of our roads.  The route is created correctly with measure units in meters, but when I attempt to use miles, the issue I have is as follows.  I did a test with only one street.  The street and route feature class are in a feature dataset with a state plane projection, units in meters.  I used the default M resolution for the output feature dataset of 0.0001 (also tried 0.00001).  The street is 0.6 miles long.  Using the Create Routes  tool I applied a measure factor of 0.000621371192 (conversion from meters to miles).  The route created has vertices with zero measures where the steet is less than 0.5 miles in length, then vertices with measure values of 1 for vertices where the street is above .5 miles in length. (see attached image). I also tried to add a miles field to the street and reference this when creating the route with the same effect.  How can I keep the measure from being rounded to the nearest integer?

Attachments

Outcomes