AnsweredAssumed Answered

Trouble with Attachment Tools

Question asked by khighlan on May 27, 2014
Latest reply on Jun 2, 2014 by khighlan
Hi there,

I'm running into some problems when using the Attachments tools. We're assigning traffic signs of a certain MUTCD code a single image of what that sign looks like (e.g. all stop signs will have the same attachment, which is a picture of a stop sign). I'm testing out the Generate Attachment Match Table and Add Attachments tools, but can't seem to get the attachments to actually get to signs.

Here are the details:

  • I have a folder with the jpg image of the stop sign on my desktop. The name of the image is R1-1, which is the MUTCD code for stop signs.

  • I have map open with only the sign feature class. Feature class is stored on SDE.

  • I open up the Generate Attachment Match Table tool. Input Dataset is my feature class, Input Folder is the path to the folder I describe above, Output Match Table has been pointed to a file geodatabase on my desktop, and the key field is MUTCD. Store Relative Path is checked.

  • I run the tool and the match table has the correct number of features for stop signs, with the features' OBID in the MatchID field and all records are pointed to the R1-1.jpg with the Filename field.

  • I now open the Add Attachments tool. Input Dataset is my feature class, Input Join Field is OBJECTID, Match Table is the match table in my file geodatabase, Match Join Field is MatchID, and Match Path Field is Filename. Working Folder is pointing to the folder where R1-1.jpg is.

  • When I run the tool, I'm seeing a message in the Results tab for each ObjectID in the match table that says something like, "Cannot add file 'C:\Users\khighland\Desktop\Test\R1-1.jpg' to feature with OID = 1571"

But I don't understand why it's not allowing me to add the files. Does anyone have a clue why this is happening? Am I not allowed to assign a single attachment to multiple features, with the assumption it will copy the attachment x amount of times for however many features match this MUTCD?

Using 10.1 SP1 with an Advanced license on a WIN7 PC with local admin rights.


Any info/advice would be greatly appreciated.
Kevin

Outcomes