imgooch

file geodatabase issues

Discussion created by imgooch on May 13, 2014
Latest reply on May 13, 2014 by imgooch
I've been fighting with some sort of issue with my file geodatabase for quite some time and would like to resolve it.  I see 2 different issues regularly but I'm unsure if they could be related.

  1. My map mxd's constantly need to have "repair data source" done to the layers despite no changes to the gdb naming or location.  I just repoint it to the same thing it's already pointed to.

  2. I have a few models that I use to update some feature layers in that gdb and they fail almost every time with that error (000210) that suggests a schema lock --  which I also get sometimes when doing other housekeeping.


I am the only user here so I assure you no one else is accessing the gdb, nor am I, so I do not know why the schema lock thing is a constant issue.  I actually had to split up my one model because it kept failing due to a lock...which apparently the model itself created and didn't release.  I now have to run the first model, close ArcMap/Catalog, then run the 2nd model.   Well for the past 6 months or so I can't even get that done cause my first model fails to create output into the gdb for no apparent reason. (the failure happens when it attempts to copy a shapefile into the gdb)

I've tried running the models via a python script so that I didn't have ArcMap/Catalog open at all but the scripts fail saying a mix of "layer already exists" or "layer doesn't exist" when the former is just false and the latter is cause the model didn't create it yet!  ugh!

The gdb is located on a server machine and I've tried changing the path from a mapped drive to the UNC path and it didn't change anything.

Eventually I try it over and over again and it works but this has been making me lose my hair so I'm hoping I can get some help.

Is it possible that my gdb is corrupted?  If so, what is the best way to recreate it (copy/paste doesn't fix anything)?

Thank you for any ideas you may have!

Outcomes