AnsweredAssumed Answered

Core runtime crashes when opening geodatabase file

Question asked by jamesrichards on May 7, 2014
Latest reply on May 19, 2014 by SBaskaran-esristaff
I created a geodatabase file in ArcMap using the Share As - Runtime Content menu option. After sideloading the geodatabse to a sample app, the app is crashing when attempting to open the file with the code:

NSString *gdbPath = [self gdbDocumentsPath]; NSError *error = nil; self.geodatabase = [[AGSGDBGeodatabase alloc] initWithPath:gdbPath error:&error]; if (error) {     NSLog(@"error loading geodatabase: %@", [error localizedDescription]); }


The crash is logged to the XCode Console as:

libc++abi.dylib: terminating with uncaught exception of type Esri_runtimecore::Geodatabase::geodatabase_error: std::exception


A few notes:

  • The mxd passed validation (i.e. - Analyze) prior to sharing the runtime content and no warnings or errors were given

  • I would expect an NSError to be passed back from the initWithPath:error: method, but instead the app never gets beyond this line - It just crashes

  • The console log message gives no clue as to what the problem might be

  • I also tried publishing the mxd to a Feature Service, and creating the geodatabase replica via ArcGIS Server and got the same result

By repeatedly removing layers from my mxd and recreating the geodatabase I have narrowed the problem down to some specific layers. I can provide a runtime geodatabase with one of these layers if you need it to reproduce the error.

Cheers,
James

Outcomes