dorotastanczak

adding relationship class

Discussion created by dorotastanczak on May 7, 2014
Latest reply on May 7, 2014 by jborgion
Hello, my problem is probably easy to solve. But I don't know how and I can't find solution. It is about adding relationship class to the Map. I created relationship class between two layers in geodatabase directly (I tried also creating relationship class in feature class dataset). Everything is created correctly (cardinality - I tried one-to-one and one-to-many, primary keys etc.). I can see relationship class in Catalog tree but I can't add relationship class to the Map. I get "Could not add specified data object to the map". How can I handle this?
I think that everything is ok with geodatabase since I can create relationship class (many-to-many) between a layer and non-spatial table and add it to the View.

The layers for the problematic relationship class are empty - since this is only template for database, but that was not a problem in creating relationship class with non spatial table.

I would really appreciate some advice.

Cheers,
Dorota

Outcomes