deleted-user-yA_w_FC9FKe5

Javascript simple issue with iPad

Discussion created by deleted-user-yA_w_FC9FKe5 on May 2, 2014
My code is working fine in IE9 on my desktop but when I try to use it on the iPad I get to the first alert box but the second does not activate so I believe I have an issue below.  At first I used the dojo and once I saw my code was stopping here I decided to try something I know worked for a similar application  Any idea why it would be stopping here.

If I take out this part and comment out this line then everything works, well with out any graphics ;-)

   //resultFeatures[i].setSymbol(symbol);


I've included these:
  dojo.require("esri.symbols.SimpleMarkerSymbol");
               dojo.require("esri.symbols.SimpleLineSymbol"); 
  dojo.require("dojo._base.Color");
  dojo.require("esri.graphic");
dojo.require("esri.Color");

alert ("Found Symbols")

//Create symbols for graphics
 //var symbol = new esri.symbols.SimpleMarkerSymbol(
//          esri.symbols.SimpleMarkerSymbol.STYLE_CIRCLE, 
//          12, 
//          new esri.symbols.SimpleLineSymbol(
//            esri.symbols.SimpleLineSymbol.STYLE_NULL, 
//            new esri.Color([247, 34, 101, 0.9]), 
//            1
//          ),
//          new esri.Color([207, 34, 171, 0.5])
//        );


    var symbol = new  esri.symbols.SimpleMarkerSymbol(
       esri.symbols.SimpleMarkerSymbol.STYLE_CIRCLE, 
      12, 
      new esri.symbols.SimpleLineSymbol(
     esri.symbols.SimpleLineSymbol.STYLE_NULL, 
     new dojo._base.Color([0, 0, 0, 0.9]), 
     1
      ),
      new dojo._base.Color([0, 0, 0, 0.5]))

alert ("Found DataGrid and Graphics")

Outcomes