lmagudo

Problems with a wms service

Discussion created by lmagudo on Apr 30, 2014
Hi everybody,

I´m trying to add diferents layers to my app from this link:

http://gmis.jrc.ec.europa.eu/webservices/4km/wms/pathfinder?

And I check the capabilities here:

http://gmis.jrc.ec.europa.eu/webservices/4km/wms/pathfinder/?request=getcapabilities&service=wms

In ArcMap I use this conecction and I don´t have any problem. In my app I use the next code:

//#region wmsLayers
        declare("my.nexradWMSLayer", DynamicMapServiceLayer, {
            constructor: function () {
                this.initialExtent = this.fullExtent = new Extent({
                    xmin: -180,
                    ymin: -90,
                    xmax: 180,
                    ymax: 90,
                    spatialReference: {
                        wkid: 4326
                    }
                });
                this.spatialReference = new esri.SpatialReference({
                    wkid: 4326
                });
                this.loaded = true;
                this.onLoad(this);
                console.log(this);
            },

            getImageUrl: function (extent, width, height, callback) {
                var params = {
                    request: "GetMap",
                    transparent: true,
                    format: "image/png",
                    transparent: "true",
                    bgcolor: "ffffff",
                    version: "1.3.0",
                    layers: "GMIS_P_ANO_SST_09_1981, GMIS_P_ANO_SST_10_1981",
                    styles: "default,default",
                    exceptions: "application/vnd.ogc.se_xml",
                    //changing values
                    bbox: extent.xmin + "," + extent.ymin + "," + extent.xmax + "," + extent.ymax,
                    srs: "EPSG:" + extent.spatialReference.wkid,
                    width: width,
                    height: height
                };
                callback("http://gmis.jrc.ec.europa.eu/webservices/4km/wms/pathfinder?" + ioquery.objectToQuery(params));
            }
        })

        wmsLayer = new my.nexradWMSLayer();
        map.addLayer(wmsLayer, 0);


When run this code, my map is empty and I don´t have errors. I don´t know where is the problem :confused:.

Thank you,
Luis Miguel

Outcomes