GlobalAdams

After 10.2.1 update Arcpy 64 bit ERROR

Discussion created by GlobalAdams on Apr 14, 2014
Latest reply on Apr 14, 2014 by mzcoyle
I've updated my ArcGIS desktop version from 10.2 to 10.2.1 and have noticed that when I run the 64 bit version of IDLE I now get an error when trying to import arcpy:

Python 2.7.3 (default, Apr 10 2012, 23:24:47) [MSC v.1500 64 bit (AMD64)] on win32
Type "copyright", "credits" or "license()" for more information.
>>> import arcpy

Traceback (most recent call last):
  File "<pyshell#0>", line 1, in <module>
    import arcpy
  File "C:\Program Files (x86)\ArcGIS\Desktop10.2\arcpy\arcpy\__init__.py", line 24, in <module>
    from arcpy.toolbox import *
  File "C:\Program Files (x86)\ArcGIS\Desktop10.2\arcpy\arcpy\toolbox.py", line 656, in <module>
    from na import AddFieldToAnalysisLayer as AddFieldToAnalysisLayer_na
  File "C:\Program Files (x86)\ArcGIS\Desktop10.2\arcpy\arcpy\na.py", line 26, in <module>
    import _na
  File "C:\Program Files (x86)\ArcGIS\Desktop10.2\arcpy\arcpy\_na.py", line 46, in <module>
    class StreetDirectionsProperties(na.StreetDirectionsProperties):
AttributeError: 'module' object has no attribute 'StreetDirectionsProperties'


So the error seems to come from failing to find a module for the Network Analyst extension, which I see is listed as one of the updated Python features in 10.2.1: (http://resources.arcgis.com/en/help/main/10.2/#/What_s_new_in_ArcGIS_10_2_1/016w0000005v000000/). I'm guessing the 10.2.1 release didn't update both the 32 AND 64 bit versions of Arcpy when installing Python 2.7.5. The version I still have in C:\Python27\ArcGISx6410.2 is 2.7.3, but this seems to now be in conflict with the new install.

Can someone please help me figure out how to correct this issue with IDLE? I really need to be able to run stand-alone 64 bit Arcpy scripts. I'm aware of 64 bit background geoprocessing in ArcMap/ArcCatalog, but this is different. I run heavy lifting stand-alone scripts that must be in the 64 bit version.

Thank you

Outcomes