simonplanells

Problem with Moran I Spatial Autocorrelation

Discussion created by simonplanells on Mar 31, 2014
Latest reply on Mar 31, 2014 by simonplanells
Dear ArcGis users,

I am trying to perform a spatial analysis in ArcGis and one of the steps is to calculate the Moran I for several distances. When I try to use the tool (or the incremental distances tool) I get the following error:
Executing: SpatialAutocorrelation "C:\Dropbox\Simon\trabajosimon\7. Futbol and crime. Spatio-temporal analysis\Arcgis\Resultados\kernel\robberies_HOME_CENSUSTRACK_SUM.shp" Sum_Rob NO_REPORT INVERSE_DISTANCE EUCLIDEAN_DISTANCE NONE # #
Start Time: Mon Mar 31 19:55:14 2014
Running script SpatialAutocorrelation...

Traceback (most recent call last):
  File "c:\program files (x86)\arcgis\desktop10.1\ArcToolbox\Scripts\MoransI.py", line 21, in <module>
    import SSReport as REPORT
  File "c:\program files (x86)\arcgis\desktop10.1\ArcToolbox\Scripts\SSReport.py", line 17, in <module>
    import pylab as PYLAB
  File "C:\Python27\ArcGIS10.1\lib\site-packages\pylab.py", line 1, in <module>
    from matplotlib.pylab import *
  File "C:\Python27\ArcGIS10.1\lib\site-packages\matplotlib\__init__.py", line 133, in <module>
    from matplotlib.rcsetup import (defaultParams,
  File "C:\Python27\ArcGIS10.1\lib\site-packages\matplotlib\rcsetup.py", line 18, in <module>
    from matplotlib.fontconfig_pattern import parse_fontconfig_pattern
  File "C:\Python27\ArcGIS10.1\lib\site-packages\matplotlib\fontconfig_pattern.py", line 23, in <module>
    from matplotlib.pyparsing import Literal, ZeroOrMore, \
  File "C:\Python27\ArcGIS10.1\lib\site-packages\matplotlib\pyparsing.py", line 71, in <module>
    import xml.sax.saxutils
  File "C:\Users\simon\Anaconda\Lib\xml\sax\saxutils.py", line 6, in <module>
    import os, urlparse, urllib, types
  File "C:\Users\simon\Anaconda\Lib\urllib.py", line 26, in <module>
    import socket
  File "C:\Users\simon\Anaconda\Lib\socket.py", line 47, in <module>
    import _socket
ImportError: DLL load failed: %1 no es una aplicación Win32 válida.

Failed to execute (SpatialAutocorrelation).
Failed at Mon Mar 31 19:55:15 2014 (Elapsed Time: 1,00 seconds)


Could anyone please tell me what is going on. I have no clue.

I am using Arcgis 10.1 and Windows 8.

Thanks for the help.

Regards

Outcomes