NeoJigglypuff

error in local hosting of an AGOL webmap

Discussion created by NeoJigglypuff on Mar 18, 2014
Latest reply on Mar 19, 2014 by NeoJigglypuff
Hi,

I have been trying to locally host this webmap I created using AGOL (to modify it):

http://dpwh.maps.arcgis.com/apps/MapTour/index.html?appid=7bd06d8330254b2688577d82f81bb92e

It uses the Map Tour template. I did step 1 of the readme file, and since I already had built the application inAGOL, skipped to step 5 and configured  configOptions to use the appid, such as it now looks like this

configOptions = {
    // Enter either a web map ID or a web application ID
    // - Using a Map Tour application ID created through the interactive builder in ArcGIS.com allow to reuse 
    //   the settings like the header configuration without having to edit any configuration here
    // - Web map and application can be dynamically specified through url parameters (webmap and appid) 
    //   if the authorizedOwners property is specified (see below)
    // - If an application id is specified, the webmap configuration isn't used
    webmap: "",
    appid: "7bd06d8330254b2688577d82f81bb92e",
    // Optional list of authorized application or web map owners
    // Has to be specified when using appid or webmap url parameters (e.g. ["user1"], ["user1", "user2"])
    authorizedOwners: [""],
    // Select the application layout between "three-panel" and "integrated"
    layout: "three-panel",
    // The application header title, if no title is specified, the webmap's title is used
    title: "",
    // The application header subtitle, if not specified the ArcGIS.com web map's summary is used
    subtitle: "",
    // Optionally force a web map layer to be used as the tour points data source (can be overridden through URL)
    // Otherwise the upper visible point layer is used (excluding map notes)
    sourceLayerTitle: "",
    // Use the first data record as an introduction instead of a point (can be overridden through URL)
    firstRecordAsIntro: true,
    // Optional zoom level to be applied for the story points following introduction (can be overridden through URL) (e.g: 0 to 16 for Gray Canvas, 0 to 19 for Street Map, -1 to disable)
    zoomLevel: -1
   };


Loading the local version however only produces a "Fatal error: Failed to get portal configuration" error. This is the case even if I only use the webmap id, or just load the page unmodified.

Help please to make this work?

Regards,
Egan

Outcomes