Amrine024

Fill Sinks Error

Discussion created by Amrine024 on Mar 17, 2014
Latest reply on Mar 17, 2014 by MBoucher21
Greetings,

I am working on a project that is modeling runoff at a county level. The DEM used is lidar derived and has a 5 ft resolution. The general workflow I am flowing is

Sink evaluation---> Sink Selection (to give a minimum drainage area) ----> Fill sinks (using the deranged polygon from the sink evaluation and the 'Use IsSink field' option.

When I run the fill sinks tool i receive the error:

System.Runtime.InteropServices.COMException (0x80041098): ERROR 010429: Error in GRID IO: MtVatBldNew: Value range for c:\users\user\appdata\local\temp\arcc79c\ah2014~4\tmp2675  exceeds 100000 .
ERROR 010429: Error in GRID IO: and number of unique values exceeds 500 ..
ERROR 010236: Error in building VAT.
ERROR 010067: Error in executing grid expression.
   at ESRI.ArcGIS.GeoAnalyst.RasterConversionOpClass.ToRasterDataset(IGeoDataset dataset, String rasterFormat, IWorkspace pWorkspace, String name)
   at ESRI.APWR.ApHydro.ArcHydroOp.FillSinks(ApLayers& aplayers, Boolean useIsSink, Boolean fillAll, Double fillLimit, ITrackCancel trackCancel, IGPMessage messages, String& exMessage) in C:\Builds\HydroSolutions\10.1_ArcHydro\Sources\ArcHydroTools\src\ApHydro\ArcHydroOp.vb:line 57592
Failed to execute (FillSinks).


I thought this was telling me that the DEM was too large in size, so I tried running the tool again with several subsets by using a polygon to determine the processing extent. This results in the same error and I am not sure why. I have tried the usual fixes (deleting temp files, checking output locations, using the toolbox vs. the toolbar) and the error still occurs.

Like I said, I assume its telling me the tables I am using are too large, but I have made the subsets very small and the error continues.

Can anyone offer insight on this or help me figure out what I am doing wrong? Thanks for any help that can be offered.

Outcomes