shepa006

Option to Reference Enterprise Data is Disabled/Greyed Out

Discussion created by shepa006 on Mar 7, 2014
I'm creating a map package for use in a WPF for Runtime application. When creating the map package if I check 'Support ArcGIS Runtime' then it greys out and checks the option 'Include Enterprise Geodatabase data instead of referencing the data.' I need to reference the enterprise geodatabasse data, not include it. If I choose the 'Reference all Data' option then it does uncheck the 'Include...' option however when I use the package in the WPF application there are no layers in the service. If I include the data then it loads fine with the layers.

Why does checking 'Support ArcGIS Runtime' disable and check the option to 'Include Enterprise Geodatabase data instead of referencing the data'? How can I resolve this so that the data is referenced?

The Enterprise Geodatabase is running in SQL Server Express for this. I have also tried adding the layer to ArcMap using a connection with OS Auth and tried another one using database auth. Both (OS and Database Auth) fail to load the data that I want to reference.

Outcomes