Mconst5

Help with Create TIN variables

Discussion created by Mconst5 on Mar 7, 2014
Latest reply on Mar 10, 2014 by Mconst5
I am writing a script that includes creating TINs and it won't allow me to use a variable for the input feature class.  I get a warning that says "Not a member of none". 

It works if I hard code the shapefile in the parameters but not when I use a variable.

the code snippet that isn't working:

# Output TIN
BuildingBase = "BldgBase"
Roof = "BldgRoof"

# Input point feature classes
elevpntsRoof = "elevpntsRoof.shp"
elevpntsbase = "elevpntsBase.shp"

# execute create TIN 3d
arcpy.CreateTin_3d(Roof, Coordinate_System, "elevpntsRoof elev Mass_Points <None>", "DELAUNAY")
arcpy.CreateTin_3d(BuildingBase, Coordinate_System, "elevpntsbase elev Mass_Points <None>", "DELAUNAY")

The error:
ExecuteError: Failed to execute. Parameters are not valid.
ERROR 000800: The value is not a member of <None>.
Failed to execute (CreateTin).

I want this script to allow users to input their variables without having to go into the script
so far the script only works when I add the feature class path directly to the parameters within the ("elevpntsRoof elev Mass_Points <None>") part of arcpy.CreatTin_3d.

This works fine:

arcpy.CreateTin_3d(Roof, Coordinate_System, "elevpntsRoof.shp elev Mass_Points <None>", "DELAUNAY")

Is it because of the "" or does it not work using variables at all.  I have tried no quotes, {}, [], no "" around the variable but nothing has worked.

Thanks

Outcomes