atschool

Sublayers Network Analysis not found when unchecking 'display geoprocessing result'

Discussion created by atschool on Jan 19, 2014
Hello,

I'm writing a script that calculates routes for +600.000 records by using the 'for'-function. When the route is calculated, it is saved in a general layer, thus summarizing all routes that are calculated. Some extra data is related to every route. I run my scripts in the ArcGIS Python Window.

When I run this script, it all works, but after less than 1000 records, I get an error 'Out of memory'. In a couple of weeks I'm upping to a better laptop, but for now, I'd like to know how I can avoid this problem.

One thing I tried is to uncheck the 'Display results' in the Geoprocessing Window. I thought that not displaying every result, and especially the file containing all routes, would enhance the performance. Yet, when I uncheck this box, ArcGIS returns an 000732 error, saying the r"Route/Routes sublayer kan not be found. Does anyone know how to fix this?

Kind regards,
Koos

Outcomes