laylaz

Issue with Clipping a Shapefile to Mosaic

Discussion created by laylaz on Jan 17, 2014
Latest reply on Jan 22, 2014 by cdartiguenave-esristaff
Hello,
I am trying to clip a stream to my mosaic layer. But it???s not working.
I downloaded all my data from USGS.  I created the mosaic file out of the several img files (DEM) following this instruction:
ArcCatalog > New Geodatabase > Rightclick > New Mosaic Dataset > Rightclick > Load data > and picked all my img files as input.
Afterwards, I opened a new ArcMap file and added the mosaic layer I had created in the previous step.
The ways I tried to clip:
1) Used the Geoprocessing tab > Clip > but the Mosaic layer wouldn???t show on the ???Clip Feature??? (or ???input feature???) section.

2) ArcToolbox > Raster > Raster Processing > Clip

But with this path, the only thing that I can do is Clip the RASTER to the Shapefile.  I want to do vice versa.

Could anyone help me with this issue please?

p.s. I tried to make a polygon out of my mosaic so that I use the polygon for clipping, but I couldn???t get it to make the polygon.  Toolbox > Conversion Tools > From Raster > Raster to Polygon > input  my mosaic file but it gives me the following error:
ERROR 000864
Input raster: The input is not within the defined domain. ERROR 000863: Invalid GP data type

Outcomes