kaldinge

Error: Unclosed rings leads to Drawing Errors and loss of functionality

Discussion created by kaldinge on Jan 13, 2014
Latest reply on Feb 11, 2014 by kimo
Hello,

I have a polygon shapefile that was originially created in eCognition.  This is a large file (>47,000 polygons) that was intended for land cover classification.  Because the area I am working with didn't classify well automatically, I am using ArcMap 10.1 to manually classify the polygons.  This sounds like a ton of work to do by hand, but about 80% of the image is forest, so it's not too bad.  I have been using the Editing toolbar to enter the land cover class into the attribute table for selected polygons.

Last week, when I added the shapefile to ArcMap, I got an ArcMap Drawing Error (One or more layers failed to draw: Land_cover: There was a problem drawing the shapefile. Drawing aborted.).  I used the Check Geometry tool and discovered that a polygon had "unclosed rings".  I used the Repair Geometry tool in an attempt to fix, but that did not appear to correct the error.  ArcMap will draw all of the polygons up until the one with unclosed rings, then it stops.  I tried deleting the "broken" polygon, but no luck.  I can even open the attribute table and see ALL of the polygons listed, but functionally I can't do anything with the polygons after the one that has an error.

I zoomed in on the polygon with the error and it almost looks like there is a blank space the size of a 1x1 meter pixel that may have interrupted drawing?  I have seen before on my maps where blank pixel-sized gaps will appear in the middle of a polygon.

Does anyone have any experience with something like this?  Any suggestions as to how to fix the shapefile?

Kyle Aldinger

Outcomes