Desktop 10.2/ Server 10.2 - Unable to publish any geoprocessing results as GP Service

Discussion created by trudnick on Oct 28, 2013
Latest reply on Jun 17, 2015 by anaqi
I've been having trouble for the past several days with the process of publishing geoprocessing results as a GP service. I started out with my own script, and when I could not get the GP results to publish I tried the Clip and Ship sample, and when publishing those results did not work I set up something ridiculously easy (model which counts from 1-100, no data involved whatsoever). I was unable to publish the GP results from any of the models.

Here's what happens: I can run the model, no matter which script I tried I was successful with getting GP results. I can go through the wizard for 'Share As Geoprocessing Service', and the Analyze tool finds no problems with anything. If I close the wizard before I get to the staging point, the sddraft file is created with no errors. When I either continue in the wizard with creating the service, or reopen the sddraft file and click STAGE, I get to the point where it says PACKAGING IN PROGRESS and then ArcCatalog or ArcMap crashes completely with no other message than 'ArcCatalog Application has stopped working. A problem caused the program to stop working completely. Please close the program.' No error message, no option to send error results to ESRI.

This happens both in ArcMap and ArcCatalog, and it happens with Background Geoprocessing off or on. It has happened both on a server machine and on my desktop with Windows 7. Both machines are Python 32-bit with no 64-bit Python installed.

The Server logs show nothing, as the service never gets far enough to actually be published to Server.

Any ideas about what might be happening? I'm not even sure where to LOOK at this point. I even tried pulling the staging out into a one-line Python script using arcpy.StageService_server, and it crashed Python with no error message.