jdeangelo

Problem importing stats from scipy with new Arc10.1 install

Discussion created by jdeangelo on Oct 26, 2013
Latest reply on Oct 29, 2013 by stacyrendall
Hi All,

I have a new machine with a fresh install of Arc10.1.  My script can import scipy, but when I try

from scipy import stats

I get:

Traceback (most recent call last):
  File "C:\ArcProjects\BasinLoop3_All6.py", line 13, in <module>
    from scipy import stats
  File "C:\Python27\ArcGISx6410.1\lib\site-packages\scipy\stats\__init__.py", line 324, in <module>
    from .stats import *
  File "C:\Python27\ArcGISx6410.1\lib\site-packages\scipy\stats\stats.py", line 242, in <module>
    import scipy.special as special
  File "C:\Python27\ArcGISx6410.1\lib\site-packages\scipy\special\__init__.py", line 531, in <module>
    from ._ufuncs import *
ImportError: DLL load failed: The specified module could not be found.


I have tried several scipy installs and I get the same result with each:

scipy-0.13.0-win32-superpack-python2.7.exe
scipy-0.13.0.win-amd64-py2.7.exe
scipy-0.11.0-win32-superpack-python2.7.exe

I figure it has to do do with some incompatibility with the different numpy, scipy versions and the version of python that came with Arc10.1 (py2.7).  Also you can see from my error that my script (ran in IDLE) that it is trying to run this with 64bit python.  Can someone help me sort out what's going on here?

Thanks...

Outcomes