halljames

GeoRSS files - trouble loading from our web server using API

Discussion created by halljames on Oct 18, 2013
Hi there.

I am having trouble with using GeoRSS files, or more specifically, GeoRSS files stored on our server.  I have a feeling it has something to do with the way our web server is set up.

The RSS file I am trying to display is : https://test.sunderland.gov.uk/WEBAPPS/WSS/Sunderland_Portal/rss.xml

This is just a test file as normally it would come from an aspx page, but to try and rule out issues, I have created a static file.  If I try to display it using for example, the sandbox at http://developers.arcgis.com/en/javascript/sandbox/sandbox.html?sample=layers_georss it doesn't work, and in the console it simply says :

dojo.io.script errorError: File not found. Wrong url.

I have tried the same file stored on a drop box account, and it works fine.  I had thought that maybe it was because it is via https, but when I tried the file on the drop box account, it was https as well.

The only thing that might affect it is that our web server is not actually https, rather it is http, but our Content Switch maps it via https (or something).

Does anyone have any ideas, or possibly even could try it themselves.  I think the error comes from the actual ArcGIS servers (as the web routines are the ones that actually retrieve the feed, not the local client, I think), and as a result, can't debug it :(

Incidentally, using the file with google maps worked okay but I think google maps downloads the rss file on the client, not sure though...

Thanks.

Outcomes