stsnider

Unable to connect to publishing tools service

Discussion created by stsnider on Oct 9, 2013
Latest reply on Jul 8, 2014 by jackwchen
I'm on ArcGIS Server 10.2.  When I try to publish a map service from ArcMap, I get an error mesage:

Error:  "Unable to connect to publishing tools service. Verify the service is up and running.  Please consult the GP Results Windows for enhanced error description or contact your admin for server logs." 

I checked and the Publishing Tools service is running.  I am successful in publishing a map service when I create a service definition file first, then use Manager to publish the service from the SD file.  Why is it that I can't publish from ArcMap directly?  There are no errors in the log files for ArcGIS Server.  The GP Results windows provide the same error message as the one stated above.  I tried stopping and starting the ArcGIS Server service thinking that the publishiing tools service was corrupted somehow, but it still gives the error message after the restart.  I get the error message in ArcMap when I try to publish as either an admin or a publisher.

Outcomes